<br><font size=2 face="sans-serif">It appears that this is a bug in Zope
2.7.6+. See http://www.zope.org/Collectors/Zope/1810. &nbsp;I haven't tried
the bug reporter's patch - the issue is still listed as &quot;pending&quot;
so I assume this isn't an official Zope patch (if there is such a thing).</font>
<br>
<br><font size=2 face="sans-serif">--David</font>
<br>
<br><font size=2 face="sans-serif">__________________</font>
<br>
<br>
<br>
<br><font size=2><tt>I got no reply from plone-users on this issue. I believe
it's really a<br>
CMF issue anyway, but got no help from the CMF list either. :(<br>
</tt></font>
<br><font size=2><tt>AFAIK, Plone's undo_tool and listUndoableTransactionsFor()
method are<br>
derived directly from the underlying CMF or Zope.<br>
</tt></font>
<br><font size=2><tt>Any help greatly appreciated!<br>
</tt></font>
<br><font size=2><tt>--David<br>
</tt></font>
<br><font size=2><tt>-----------<br>
</tt></font>
<br><font size=2><tt>In my site the undo form is always blank. In the ZMI,
however, undoable<br>
transactions are listed. I think the problem may be related to the fact<br>
that I am using a higher level user folder (RemoteUserFolder, outside<br>
Plone b/c doesn't integrate) for members. Here is my ZODB:<br>
</tt></font>
<br><font size=2><tt>| root<br>
|<br>
|_WWW</tt></font>
<br><font size=2><tt>|<br>
|_acl_users (RemoteUserFolder)<br>
|<br>
|_plone (no acl_users inside plone)</tt></font>
<br>
<br><font size=2><tt>Undoable transactions in the ZMI list plone users
as &quot;WWW [user]&quot;. There<br>
are no errors in error_log.<br>
</tt></font>
<br><font size=2><tt>Zope 2.7.6-final/linux2<br>
Python 2.3.4<br>
Plone 2.0.5<br>
</tt></font>
<br><font size=2><tt>Thanks for any help!<br>
</tt></font>
<br>
<br><font size=2><tt>_______________________________________________<br>
triangle-zpug mailing list<br>
triangle-zpug@starship.python.net</tt></font>
<br><font size=2><tt>http://starship.python.net/mailman/listinfo/triangle-zpug</tt></font>