[triangle-zpug] Plone newbie with rendering issue

Chris Calloway cbc at unc.edu
Fri Dec 7 18:00:05 UTC 2007


Stephanie Thirolle wrote:
> On this site:  https://collaborate.nicholas.duke.edu/blog/hawaii/

What's in the water at Duke that y'all keep coming up with the best 
looking Plone skins?

> I have a rather large banner that I've set as the background image for 
> #portal-header.  Trouble is that at screen sizes smaller than 19", IE 
> and Opera both add a good amount of padding beneath it -- pushing the 3 
> columns of my layout down.  Firefox and Mozilla render things fine. 

Unfortunately, this is not only a CSS thing, but is very hard to solve 
because IE and Opera don't have visual CSS debugging tools like Firefox 
does.

So one thing I'm seeing is this is a fixed width layout. The default 
portal-logo, which is a background image, is for the default liquid layout.

You may want to change that in your skin to an img tag in the 
global_logo template. I've messed with that one when I've had weird 
IE-dependent layout issues. CSS in IE is just broken beyond recognition 
and so you have to play with it.

You may also want to pose the question on the Plone UI list, which says 
it "can be used for CSS questions, usability advice - and is also the 
official mailing list for the Plone UI team."

http://lists.plone.org/mailman/listinfo/ui

There are people on that list who know everything not just about browser 
quirks, but which browser quirks affect Plone's CSS. In fact, I see 
someone asking a portal-logo question on that list just today. :)

-- 
Sincerely,

Chris Calloway
http://www.seacoos.org
office: 332 Chapman Hall   phone: (919) 962-4323
mail: Campus Box #3300, UNC-CH, Chapel Hill, NC 27599







More information about the triangle-zpug mailing list