[triangle-zpug] Unable to add new Plone Workflow

Chris Calloway cbc at unc.edu
Thu Mar 23 21:39:42 CET 2006


Veda Williams wrote:
> I wanted to add a fresh Plone Workflow for a 2.1 site via portal_workflows,
> but when I choose Plone Workflow (or any others, for that matter), and say
> "Add", I get an error:
> 
>  Error Type
>     BadRequest
> Error Value
>     ('Empty or invalid id specified', '')
> 
> This happened to me previously on 2.0.5, but it seems to be a problem for
> 2.1 as well. 
> 
> Am I the only one experiencing this problem? I'm working off of a fresh 2.1
> plone instance. I also tried it with Joel's PloneWorkflow installed, but
> still no luck. 

Drats. I had no problem doing this on a 2.1.1 instance (Fedora Core 4). 
I hate it when that happens.

The thing to do is go into your error log and cut and paste the 
traceback for us so we know where the BadRequest exception occured and 
we can work backwards from there (or even, use Wing!).

'Empty or invalid id specified,' however, is indicative that you did not 
give your new workflow an id. On the Add Workflow form:

portal_workflow/?%3Amethod=manage_addWorkflowForm&submit=Add+Workflow

you should see a form field to specify the Id of your new workflow. 
Every Zope object needs one. It must be unique in the same folder.

We are doing this on a test instance and not production, correct? We 
want to develop our workflows on a test instance, and then bake it out 
to the filesystem with DCWorkflowDump when we're happy with it. We can 
then check that filesystem workflow code into version control and roll 
it out to our production system from there.

-- 
Sincerely,

Chris Calloway
http://www.seacoos.org
office: 17-6 Venable Hall   phone: (919) 962-4323
mail: Campus Box #3300, UNC-CH, Chapel Hill, NC 27599







More information about the triangle-zpug mailing list