[triangle-zpug] undo issue

David Chandek-Stark chand012 at notes.duke.edu
Sat Jul 30 08:11:20 CEST 2005


It appears that this is a bug in Zope 2.7.6+. See 
http://www.zope.org/Collectors/Zope/1810.  I haven't tried the bug 
reporter's patch - the issue is still listed as "pending" so I assume this 
isn't an official Zope patch (if there is such a thing).

--David

__________________



I got no reply from plone-users on this issue. I believe it's really a
CMF issue anyway, but got no help from the CMF list either. :(

AFAIK, Plone's undo_tool and listUndoableTransactionsFor() method are
derived directly from the underlying CMF or Zope.

Any help greatly appreciated!

--David

-----------

In my site the undo form is always blank. In the ZMI, however, undoable
transactions are listed. I think the problem may be related to the fact
that I am using a higher level user folder (RemoteUserFolder, outside
Plone b/c doesn't integrate) for members. Here is my ZODB:

| root
|
|_WWW
|
|_acl_users (RemoteUserFolder)
|
|_plone (no acl_users inside plone)

Undoable transactions in the ZMI list plone users as "WWW [user]". There
are no errors in error_log.

Zope 2.7.6-final/linux2
Python 2.3.4
Plone 2.0.5

Thanks for any help!


_______________________________________________
triangle-zpug mailing list
triangle-zpug at starship.python.net
http://starship.python.net/mailman/listinfo/triangle-zpug
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://starship.python.net/pipermail/triangle-zpug/attachments/20050730/7ebffb99/attachment.htm


More information about the triangle-zpug mailing list