[Python-de] zlib - Zope 2.8.4 und Python 2.3.6

Katja Süss k.suess at gmx.net
Do Dez 14 15:42:08 CET 2006


Hallo *
Ich möchte Python 2.3.6 auf einer RedHat-Installation installieren.
Zope 2.8.4 fragt beim configure nach zlib.
Dies lässt sich nicht nachinstallieren. Eine Fehlermeldung kommt nicht.

# make install
cp zlib.h zconf.h /usr/local/python2.3.6/include
chmod 644 /usr/local/python2.3.6/include/zlib.h /usr/local/python2.3.6/include/zconf.h
cp libz.a /usr/local/python2.3.6/lib
cd /usr/local/python2.3.6/lib; chmod 755 libz.a
cd /usr/local/python2.3.6/lib; if test -f libz.so.1.2.3; then \
  rm -f libz.so libz.so.1; \
  ln -s libz.so.1.2.3 libz.so; \
  ln -s libz.so.1.2.3 libz.so.1; \
  (ldconfig || true)  >/dev/null 2>&1; \
fi
cp zlib.3 /usr/local/python2.3.6/share/man/man3
chmod 644 /usr/local/python2.3.6/share/man/man3/zlib.3

sagt zwar, dass libz.so angelegt wird, ist aber nachher nicht zu finden.

Was kann ich da tun?

Danke und Gruss, 
Katja