[Python-de] setuptools installieren keine data files

Andreas Pakulat apaku at gmx.de
Die Jun 27 09:57:51 CEST 2006


Hi,

hab hier ein Problem mit den setuptools, irgendwie schmecken denen meine
.ui-Dateien nicht. Trotz meiner Meinung nach korrekter setup.py werden
nur die Python-Dateien ins egg gepackt...

,----[ setup.py ]-
| import os
| import sys
| from setuptools import setup, find_packages
| 
| pyqt4version = None
| 
| try:
| 	from PyQt4 import pyqtconfig
| 	pyqt4version = pyqtconfig._pkg_config['pyqt_version']
| except ImportError:
| 	pass
| 
| if pyqt4version is None or pyqt4version <0x040000:
| 	print """XPathEvaluator depends on PyQt4 Version 4.0.0 or higher
| to be installed"""
| 	sys.exit(1)
| 
| 
| addargs = {}
| 
| setup(name="XPathEvaluator",
|       version="0.4.0",
|       description="Displays XML Trees and shows results of XPath Evaluations on them",
|       long_description="XPathEvaluator can be used to test XPath expressions in a visual way. It highlights the nodes returned by an XPath expression. It also shows how good different xml implementations are.",
|       author="Andreas Pakulat",
|       author_email="apaku at gmx.de",
|       url="http://www.apaku.de/linux/xpathevaluator",
|       license = "GPLv2",
|       packages = ["xpathevaluator"],
|       scripts = ["xpathevaluator.py"],
|       package_data = {
|       	'ui' : ['*.ui'] },
|       **addargs)
`----

Also was mache ich da falsch?

Achja, Ordnerstruktur ist folgendermassen:

project-dir
  |
  |- xpathevaluator (mit den .py-Dateien)
  |
  |- ui (mit den ui-Dateien
  |
  |- setup.py
  |
  |- xpathevaluator.py

Andreas

-- 
Everything will be just tickety-boo today.