[Python-de] Informix

Christian Klinger cklinger at novareto.de
Mon Dez 20 12:51:47 CET 2004


Hallo,

kann jemand von euch noch einmal beschreiben ob das geklappt hat und wie 
es gegebenenfalls funktioniert.

Ich stehe nämlich vor dem gleichen Problem!

Ich versuche es allerdings, bisher erfolglos, mit diesem Modul. 
(Probleme beim kompilieren)

http://zope.org/Members/papa/



mfg Christian


>Hallo Roland,
>
>~ ich hatte die API damals mit einer python 1.5 erstellt und dann in
>meine aktuelle Version eingebunden.
>
>Oder ersetze in configure
>~     # for Python 1.5 and later, use the installed Makefile.pre.in
>~     cp_mfprein="cp $exec_prefix/lib/python1.5/config/Makefile.pre.in
>$srcdir/ext/Makefile.pre.in"
>
>durch
>
>~     # for Python 1.5 and later, use the installed Makefile.pre.in
>~     cp_mfprein="cp $exec_prefix/lib/python2.3/config/Makefile.pre.in
>$srcdir/ext/Makefile.pre.in"
>
>
>Dann müßte es eigentlich funktionieren.
>
>Gruß
>
>Gerhard
>- ------------
>Roland M. Kruggel wrote:
>|/ Am Samstag 04 September 2004 16:06 schrieb Gerhard Quell:
>/|/
>/|>/Hallo Roland,
>/|>/
>/|>/~ es gibt eine Informix Database API:
>/|>/http://starship.python.net/crew/sturner/informixdb.html
>/|/
>/|/
>/|/ Eigentlich genau das was ich suche.
>/|/
>/|/
>/|>/Sie ist zwar schon ziemlich alt, d.h. sie wurde mit python 1.5
>/|>/erstellt. Wahrscheinlich mußt Du ein bißchen tricksen. Wenn Du
>/|>/ihn neu erstellen willst, brauchst esql/c.
>/|/
>/|/
>/|/ Da beisse ich mit python 2.3 auf Granit. Bekomme das Teil nicht
>/|/ kompiliert. ./configure steigt schon aus.
>/|/
>/|/
>/|>/Die andere Alternative wäre, einen ODBC-Treiber zu verwenden.
>/|/
>/|/ Ich habe einen mxODBC von eGenix.com gefunden. Ist das Ding
>/|/ brauchbar?
>/|/
>/|/
>/|/
>/|>|/ Hallo Liste,
>/|>|/
>/|>|/ ich habe eine Informix SE Datenbank laufen. Wie kann ich diese
>/|>|/ von Python aus ansprechen?
>/|/
>/|/
>/|/ cu
>/|
>