[Python-de] Das Modul pygame

Gregor Lingl glingl at aon.at
Fri Jan 31 01:31:39 EST 2003


Fritz Cizmarov schrieb:

>Am Fri, 31 Jan 2003 01:00:22 +0100
>Schrieb Fritz Cizmarov <fritz at sol.at>:
>
>die beiden
>
>  
>
>>if version_info <= (2,2):
>>    
>>
>
>
>sollten natürlich 
>
>if version_info < (2.2):
>
>sein.
>  
>
Dacht ichs doch! ;-)

In der Tat ist aber jedes Fünfer-Tupel, das mit
(2,2,...) beginnt echt größer als (2,2):

 >>> (2, 2, 0, 'final', 0) <= (2,2)
0

und somit läft das Programm ab 2.2.x wie gehabt.
Nichtsdestotrotz zeigt die letzte korrigierte Fassung besser,
um was es geht.

Danke, jedenfalls.
Gregor

>
>Gruß
>
>Fritz
>
>_______________________________________________
>Python-de maillist  -  Python-de at starship.python.net
>http://starship.python.net/mailman/listinfo/python-de
>
>
>  
>








More information about the Python-de mailing list