[Python-de] Vorstellung und (leider) auch Problem mit xml.sax.expatreader

Stefan Schwarzer sschwarzer at sschwarzer.net
Thu Jan 2 23:17:52 EST 2003


Hallo Thilo,

willkommen auf der Liste :-)

Thilo Rößler wrote:
> Am Donnerstag, 2. Januar 2003 16:19 schrieb Gerson Kurz:
>> Hast du vielleicht eine alte Version drauf? Was gibt den folgendes
>> ~>python
>> Python 2.2.2 (#1, Nov 15 2002, 07:49:04)
>> [GCC 2.95.3-5 (cygwin special)] on cygwin
>> Type "help", "copyright", "credits" or "license" for more information.
>> >>> import xml.sax.expatreader
>> >>> print xml.sax.expatreader.__file__
> 
 > [...]
> 
> Sagt dir das was? (an meiner Fragestellung wirst du erkennen, dass mir das 
> leider nichts sagt)

Falls es tatsächlich eine Versionsunverträglichkeit ist (sieht danach aus), könntest
du Zope (bzw. den entsprechenden Python-Aufruf) mal python die Option -i verpassen.
Damit solltest du nach dem Traceback im Interpreter landen und kannst die obigen
Eingaben daraufhin untersuchen, ob sie ein anderes expat-Modul oder andere Modul-
Inhalte anzeigen.

Viel Erfolg
  Stefan





More information about the Python-de mailing list