[Python-de] Vorstellung und (leider) auch Problem mit xml.sax.expatreader

Thilo Rößler el-nino at gmx.li
Thu Jan 2 15:34:41 EST 2003


Hallo liebe Liste :-)

Ich weiss nicht ob das hier so üblich ist, aber da ich mich gerade eben bei 
dir (liebe Mailingliste) eingetragen habe, will ich mich mal schnell 
vorstellen.
Mein Name ist Thilo, ich bin 24 und seit einiger Zeit mache ich ein paar 
Sachen mit Zope ... wodurch ich dann natürlich auch mit Python in Berührung 
kam.
So weit hatte das auch alles gut funktioniert und Probleme konnte ich unter 
Zuhilfenahme des webs weitgehend selbst lösen ... zumindest bis heute (womit 
ich - langsam aber sicher - zu meinem eigentlichen Anliegen überleite).
Ich wollte heute in Zope (2.6.0) das Produkt ZooDocument installieren (was 
auch soweit gleich geklappt hat). Als ich ein OO-Dokument anlegen wollte, 
bekam ich eine Fehlermeldung, da ich wohl PyXML nicht installiert hatte ... 
also habe ich PyXML von meinen SuSE CDs nachinstalliert (in der Version 0.7). 
Beim neuerlichen Versuch, ein OO-Dokument anzulegen, überraschte mich dann 
folgende Fehlermeldung (zu der ich im web auch leider nichts brauchbares 
gefunden habe):

Traceback (innermost last): 
Module ZPublisher.Publish, line 98, in publish
 Module ZPublisher.mapply, line 88, in mapply
 Module ZPublisher.Publish, line 39, in call_object
 Module Products.ZooDocument.ZooDocument, line 297, in addZooDocument
 Module OFS.ObjectManager, line 272, in _setObject
 Module Products.ZooDocument.ZooDocument, line 67, in manage_afterAdd
 Module Products.ZooDocument.ZooDocument, line 83, in processDocument
 Module Products.ZooDocument.OpenOfficeDoc, line 58, in getDocType
 Module xml.dom.minidom, line 915, in parseString
 Module xml.dom.minidom, line 901, in _doparse
 Module xml.dom.pulldom, line 301, in parseString
 Module xml.sax, line 76, in make_parser
 Module xml.sax, line 101, in _create_parser
AttributeError: 'xml.sax.expatreader' module has no attribute 'create_parser' 

Kann mir einer sagen, was mir evtl. fehlt (nicht gesundheitlich) oder was ich 
falsch gemacht habe?
Falls ja wäre ich sehr dankbar :-)

MfG (und ein frohes Neues an alle)

Thilo




More information about the Python-de mailing list