[Python-de] wxPython unter Linux, oder: was für ein beschi**nes Konzept!

Gerson Kurz Gerson.Kurz at t-online.de
Sat Jul 6 22:18:05 EDT 2002


Ich habe ein kleines wxWindows Programm geschrieben, das unter Windows und
Linux ein GUI darstellen soll. Nachdem unter Windows der Prototyp läuft,
möchte ich das ganze unter Linux testen.

Ich gehe auf die wxPython-Seite und sehe, daß ich zuerst wxGTK brauche. Ich
lade wxGTK herunter. configure sagt, daß die glib-Version falsch ist. Ich
lade glib und gtk+ sourcen herunter. configure sagt, daß glib pkgconfig
braucht. Ich lade pkgconfig herunter; configure/make/make install klappt.
glib CMMI klappt. gtk+ configure schlägt fehl, weil atk und pango fehlen.
ich lade atk und pango herunter. configure
von pango configure schlägt fehl: checking for GLIB - version >= 2.0.0...

An dieser Stelle: AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

Ich verzichte auf CMMI und schwenke über zu den RPMs. Ich lade also
glib2-2.0.4 herunter, rpm -Uvh klappt. Dann folgendes, was so schön ist, daß
ich es einfach mal komplett zitiere. (Die RPMs habe ich natürlich immer
einzeln heruntergeladen, je nachdem was mir der Schrott vorgeschlagen hat):

linux:/home/gerson # rpm -Uvh glib2-devel-2.0.4-1gtk.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
        pkgconfig >= 0.8 wird von glib2-devel-2.0.4-1gtk gebraucht
linux:/home/gerson # rpm -Uvh gtk2-2.0.5-1gtk.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
        atk >= 1.0.0-1 wird von gtk2-2.0.5-1gtk gebraucht
        pango >= 1.0.0-1 wird von gtk2-2.0.5-1gtk gebraucht
        libatk-1.0.so.0   wird von gtk2-2.0.5-1gtk gebraucht
        libpango-1.0.so.0   wird von gtk2-2.0.5-1gtk gebraucht
        libpangox-1.0.so.0   wird von gtk2-2.0.5-1gtk gebraucht
        libpangoxft-1.0.so.0   wird von gtk2-2.0.5-1gtk gebraucht
linux:/home/gerson # rpm -Uvh pango-1.0.3-2gtk.i386.rpm
pango
##################################################
linux:/home/gerson # rpm -Uvh gtk2-2.0.5-1gtk.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
        atk >= 1.0.0-1 wird von gtk2-2.0.5-1gtk gebraucht
        libatk-1.0.so.0   wird von gtk2-2.0.5-1gtk gebraucht

(einschub: atk gibt es nicht im aktuellen RPM-Verzeichnis, sondern nur noch
in einem "old" folder).

linux:/home/gerson # rpm -Uvh atk-1.0.0-1.i386.rpm
atk
##################################################
linux:/home/gerson # rpm -Uvh gtk2-2.0.5-1gtk.i386.rpm
gtk2
##################################################
linux:/home/gerson # rpm -Uvh glib2-devel-2.0.4-1gtk.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
        pkgconfig >= 0.8 wird von glib2-devel-2.0.4-1gtk gebraucht
linux:/home/gerson # rpm -Uvh pkgconfig-0.12.0-1gtk.i386.rpm
pkgconfig
##################################################
linux:/home/gerson # rpm -Uvh glib2-devel-2.0.4-1gtk.i386.rpm
glib2-devel
##################################################
linux:/home/gerson # rpm -Uvh gtk2-devel-2.0.5-1gtk.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
        pango-devel >= 1.0.0-1 wird von gtk2-devel-2.0.5-1gtk gebraucht
        atk-devel >= 1.0.0-1 wird von gtk2-devel-2.0.5-1gtk gebraucht
linux:/home/gerson # rpm -Uvh pango-devel-1.0.1-1gtk.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
        pango = 1.0.1 wird von pango-devel-1.0.1-1gtk gebraucht
        freetype-devel >= 2.0.3 wird von pango-devel-1.0.1-1gtk gebraucht
linux:/home/gerson # rpm -Uvh freetype-devel-2.0.9-2gtk.i386.rpm
file /usr/lib/libttf.la from install of freetype-devel-2.0.9-2gtk conflicts
with file from package freetype-1.3.1-281
file /usr/lib/libttf.so from install of freetype-devel-2.0.9-2gtk conflicts
with file from package freetype-1.3.1-281
linux:/home/gerson # rpm -Uvh --force --nodeps
freetype-devel-2.0.9-2gtk.i386.rpm
freetype-devel
##################################################
linux:/home/gerson # rpm -Uvh pango-devel-1.0.1-1gtk.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
        pango = 1.0.1 wird von pango-devel-1.0.1-1gtk gebraucht
linux:/home/gerson # rpm -Uvh pango-1.0.1-1gtk.i386.rpm
package pango-1.0.3-2gtk (which is newer than pango-1.0.1-1gtk) is already
installed
linux:/home/gerson # rpm -Uvh --force -nodeps
pango-devel-1.0.1-1gtk.i386.rpm
-nodeps: unknown option
linux:/home/gerson # rpm -Uvh --force pango-devel-1.0.1-1gtk.i386.rpm
Fehler: fehlgeschlagene Paket-Abhängigkeiten:
        pango = 1.0.1 wird von pango-devel-1.0.1-1gtk gebraucht
linux:/home/gerson # rpm -Uvh --force --nodeps
pango-devel-1.0.1-1gtk.i386.rpm
pango-devel
##################################################

An dieser Stelle nochmals und etwa 5 minuten lang:
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

ich gehe ins wxGTK verzeichnis, vielleicht habe ich ja inzwischen den ganzen
kram beisamen (remember, gtk und glib liessen sich problemlos installieren).

Configure sagt:

checking for GTK - version >= 1.2.3... no
configure: error:
Please check that gtk-config is in path, the directory
where GTK+ libraries are installed (returned by
'gtk-config --libs' command) is in LD_LIBRARY_PATH or
equivalent variable and GTK+ is version 1.2.3 or above.

Obwohl glib & glibc ja angeblich installiert wurden. Ich bin still, mir
fällt nix mehr ein, Linux hat mich geschlagen.

Daraus meine unwiderlegbaren Folgerungen:

1) Das ganze Konzept ist Schrott. Soll mir ja nie wieder ein Linuxjünger was
von "DLL Hell" erzählen!

2) Wer (1) widerspricht, spricht Schmarrn.

q.e.d.

Jetzt die Frage:

Wie kriege ich wxPython unter Linux zum laufen? Kann man denn nicht einfach
alle .so's usw. in ein Verzeichnis packen und gut ist? (Ich denke mit
schaudern an die Aufgabe, mein Programm mal später verteilen zu müssen...).








More information about the Python-de mailing list