[Python-de] Tkinter installieren

Albert Hermeling Albert.Hermeling at t-online.de
Sat Sep 8 18:34:24 EDT 2001


Hallo,

vor ein paar Tagen habe ich mich entschlossen die Skriptsprache Python zu 
erlernen. Da ich mit der aktuellen Version unter Linux (Suse Linux 7.1) 
arbeiten möchte, habe ich mir den Quellcode von Python 2.1.1 besorgt und 
Python compiliert. Da ich später auch GUI`s erzeugen möchte. Habe ich die 
Setup Datei entsprechend der README geändert. Versuche ich jetzt die 
"idle.py" zur starten bekomme ich diese Fehlermeldung:

 Traceback (most recent call last):
  File "idle.py", line 11, in ?
    import PyShell
  File "PyShell.py", line 13, in ?
    from Tkinter import *
  File "/usr/local/lib/python2.1/lib-tk/Tkinter.py", line 35, in ?
    import _tkinter # If this fails your Python may not be configured for 
Tk
ImportError: No module named _tkinter

Tcl / Tk ist in der Version 8.3.3 vorhanden.

Die Setupdatei wurde von mir so geändert:

-----------------Schnipp-------------------------------------------

# The _tkinter module.
#

# *** Always uncomment this (leave the leading underscore in!):
 _tkinter _tkinter.c tkappinit.c -DWITH_APPINIT \
# *** Uncomment and edit to reflect where your Tcl/Tk libraries are:
    -L/usr/local/lib/tcl8.3 \
    -L/usr/local/lib/tk8.3 \
# *** Uncomment and edit to reflect where your Tcl/Tk headers are:
	-I/usr/local/include \
# *** Uncomment and edit to reflect where your X11 header files are:
	-I/usr/X11R6/include \
# *** Or uncomment this for Solaris:
#	-I/usr/openwin/include \
# *** Uncomment and edit for Tix extension only:
#	-DWITH_TIX -ltix8.1.8.2 \
# *** Uncomment and edit for BLT extension only:
#	-DWITH_BLT -I/usr/local/blt/blt8.0-unoff/include -lBLT8.0 \
# *** Uncomment and edit for PIL (TkImaging) extension only:
#     (See http://www.pythonware.com/products/pil/ for more info)
#	-DWITH_PIL -I../Extensions/Imaging/libImaging  tkImaging.c \
# *** Uncomment and edit for TOGL extension only:
#	-DWITH_TOGL togl.c \
# *** Uncomment and edit to reflect your Tcl/Tk versions:
	-ltk8.3 -ltcl8.3 \
# *** Uncomment and edit to reflect where your X11 libraries are:
	-L/usr/X11R6/lib \
# *** Or uncomment this for Solaris:
#	-L/usr/openwin/lib \
# *** Uncomment these for TOGL extension only:
#	-lGL -lGLU -lXext -lXmu \
# *** Uncomment for AIX:
#	-lld \
# *** Always uncomment this; X11 libraries to link with:
#	-lX11

----------------------Schnapp-------------------------------------------
------------------

Nachdem ich die Setupdatei geändert habe habe ich den Befehl "make" 
eingegeben. Der Compiler verrichtete seine Arbeit ohne Fehler. 
Installiert habe ich Python mit dem Commando "make install" was auch 
fehlerfrei ausgeführt wurde.

Nach drei Tagen rumprobieren gehen mir so langsam die Ideen aus. Ich 
hoffe das Jemand unter euch ist, der mir sagen kann wo der Fehler liegt.

Mit freundlichen Grüßen

Albert 



More information about the Python-de mailing list