<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">Dear All,<div><br></div><div>I am trying to install MMTK-2.7.5 from source and so far haven’t achieve the goal.</div><div><br></div><div>Apart from the issue with gcc warnings being treated as the errors by Xcode gcc compiler </div><div>(what I have overcome using "<font face="Courier New">ARCHFLAGS="-Wno-error=-falign-loops=16”</font>),</div><div>there is also issue with netcdf.h:</div><div><font face="Courier New"><br></font></div><div><div><font face="Courier New">#warning "Using deprecated NumPy API, disable it by " \</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New"> ^</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">In file included from Src/MMTK_DCD.c:8:</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">Include/MMTK/trajectory.h:16:11: fatal error: 'netcdf.h' file not found</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New"># include "netcdf.h"</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">          ^</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">1 warning and 1 error generated.</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">error: Command "gcc -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -Qunused-arguments -DLIBM_HAS_ERFC -D_LONG64_ -DEXTENDED_TYPES -IInclude -I/Users/anna/anaconda/lib/python2.7/site-packages/numpy/core/include -I/Users/anna/anaconda/include/python2.7 -c Src/MMTK_DCD.c -o build/temp.macosx-10.5-x86_64-2.7/Src/MMTK_DCD.o -DNUMPY=1" failed with exit status 1</font></div><div><font face="Courier New"><br></font></div><div><font face="Courier New">----------------------------------------</font></div><div><font face="Courier New">Cleaning up...</font></div><div><font face="Courier New">Command /Users/anna/anaconda/bin/python -c "import setuptools;__file__='/tmp/pip-GdnMLD-build/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-7OMPph-record/install-record.txt --single-version-externally-managed failed with error code 1 in /tmp/pip-GdnMLD-build</font></div><div><font face="Courier New">Storing complete log in /var/root/.pip/pip.log</font></div></div><div><font face="Courier New"><br></font></div><div>It happens both cases: when I use<font face="Courier New"> pip instal MMTK-2.7.5.tar.gz </font>and <font face="Courier New">python setup.py build,</font></div><div><font face="Courier New"><br></font></div><div>I tried setting NETCDF variables to proper location it did not help,</div><div><br></div><div>Thanks!</div><div><br></div><div>Anna Gorska</div></body></html>