Hi,<br /><br />try this to see where numpy thinks where it&#39;s headers are:<br />In [1]: import numpy<br />In [2]: numpy.get_include()<br />Out[2]: &#39;/usr/lib/python2.7/site-packages/numpy/core/include&#39;<br /><br />Yours,<br />Marcin<br /><br /><br />On Nov 2, 2010 3:42am, Konrad Hinsen &lt;research@khinsen.fastmail.net&gt; wrote:<br />&gt; On 1 Nov 2010, at 21:35, Ramgopal Mettu wrote:<br />&gt; <br />&gt; <br />&gt; <br />&gt; <br />&gt; building &#39;Scientific_affinitypropagation&#39; extension<br />&gt; <br />&gt; gcc-4.2 -fno-strict-aliasing -fno-common -dynamic -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch ppc -arch x86_64 -pipe -IInclude -I/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/numpy/core/include -I/System/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -c Src/Scientific_affinitypropagation.c -o build/temp.macosx-10.6-universal-2.6/Src/Scientific_affinitypropagation.o -DNUMPY=1<br />&gt; <br />&gt; In file included from Src/Scientific_affinitypropagation.c:14:<br />&gt; <br />&gt; Include/Scientific/arrayobject.h:2:30: error: numpy/oldnumeric.h: No such file or directory<br />&gt; <br />&gt; <br />&gt; <br />&gt; This latter error in turn leads to a bunch of other errors and I cannot finish building Scientific. Now, I have version 1.2.1 of numpy. Is this compatible with Scientific? Do I need a newer version, or am I missing something else? Thanks!<br />&gt; <br />&gt; <br />&gt; <br />&gt; <br />&gt; In principle NumPy 1.2 should be fine, but I haven&#39;t tested anything with it for a long time.<br />&gt; <br />&gt; <br />&gt; <br />&gt; Given the paths printed above, there should be a file<br />&gt; <br />&gt; <br />&gt; <br />&gt; /System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/numpy/core/include/numpy/oldnumeric.h<br />&gt; <br />&gt; <br />&gt; <br />&gt; on your computer but apparently it isn&#39;t because the compiler cannot find it. If the file isn&#39;t there, your NumPy installation is incomplete or broken for whatever reason. If it is there, well, then there&#39;s something wrong with gcc - but I haven&#39;t seen that case yet!<br />&gt; <br />&gt; <br />&gt; <br />&gt; As a side remark, it looks like you are on a Mac (MacOS 10.6) and use Apple&#39;s Python interpreter. Apple advises against installing any add-on modules into their Python interpreter, both to protect their own Python scripts against errors introduced by other packages and to protect your Python packages against changes during system updates. In the long run, you will be better off installing a second Python interpreter for use with NumPy, MMTK, etc.<br />&gt; <br />&gt; <br />&gt; <br />&gt; Konrad.<br />&gt; <br />&gt; --<br />&gt; <br />&gt; ---------------------------------------------------------------------<br />&gt; <br />&gt; Konrad Hinsen<br />&gt; <br />&gt; Centre de Biophysique Moléculaire, CNRS Orléans<br />&gt; <br />&gt; Synchrotron Soleil - Division Expériences<br />&gt; <br />&gt; Saint Aubin - BP 48<br />&gt; <br />&gt; 91192 Gif sur Yvette Cedex, France<br />&gt; <br />&gt; Tel. +33-1 69 35 97 15<br />&gt; <br />&gt; E-Mail: research at  khinsen dot fastmail dot net<br />&gt; <br />&gt; ---------------------------------------------------------------------<br />&gt; <br />&gt; <br />&gt; <br />&gt; <br />&gt; <br />&gt; _______________________________________________<br />&gt; <br />&gt; mmtk maillist  -  mmtk@starship.python.net<br />&gt; <br />&gt; http://starship.python.net/mailman/listinfo/mmtk<br />&gt;