[MMTK] overflowerror writeDCDPDB

Edvin Fuglebakk edvin.fuglebakk at gmail.com
Fri Feb 28 06:17:09 UTC 2014


Dear MMTK-list,

I have some problems with an MMTK build on my Mac. I suspect that it is due to configurations of MMTK dependencies (in particular I suspect netcdf), but I will post it here hoping that any of you have come across this error before.

The problem is conveniently reproduced by the MMTK example scripts. 
from MMTK-2.6.1/Examples/Trajectories, I run (on my mac):
 >python snapshot.py 
 >python dcd_export.py
Traceback (most recent call last):
 File "dcd_export.py", line 18, in <module>
   writeDCDPDB(trajectory.configuration, 'rotation.dcd', 'rotation.pdb')
 File "/Users/edvinfuglebakk/framework_laptop/python/lib/python2.6/site-packages/MMTK/DCD.py", line 124, in writeDCDPDB
   writeDCD(conf_list, dcd_file_name, 1./Units.Ang, indices, delta_t, 1)
 File "/Users/edvinfuglebakk/framework_laptop/python/lib/python2.6/site-packages/MMTK/DCD.py", line 93, in writeDCD
   MMTK_DCD.writeDCDStep(fd, x, y, z)
OverflowError: signed integer is greater than maximum

A dcd file is produced, but it is only 4K and vmd can’t load it.

On my linux build, I run exactly the same code without any problems, and I can load the dcd trajectory (which is 8K).

Any help would be appreciated. I include below the script that crashes and the software versions I am using.

Best,
Edvin Fuglebakk

*** The script that causes the crash (dcd_export.py) ***
from MMTK import *
from MMTK.Trajectory import Trajectory
from MMTK.DCD import writeDCDPDB

trajectory = Trajectory(None, "rotation.nc")
universe = trajectory.universe

writeDCDPDB(trajectory.configuration, 'rotation.dcd', 'rotation.pdb’)


*** Software versions ***
On both platforms I have versions:
Python-2.6.9
MMTK-2.6.1
netcdf-4.3.0 (built with --disable-netcdf-4)
ScientificPython-2.8	
numpy-1.6.2

I am aware that some of these are outdated, but I have my reasons to prefer them still.


More information about the mmtk mailing list