[MMTK] netCDF problem

Konrad Hinsen research at khinsen.fastmail.net
Thu Mar 3 07:48:10 UTC 2011


On 2 Mar 2011, at 23:06, Victor Muñoz wrote:

> I'm trying to install the MMTK into my computer, but I just couldn't  
> make it work. I run in Ubuntu and I have already installed numpy,  
> netCDF (with the --enable-shared option) and Scientific python. The  
> problem comes after installing the MMTK. When I try to run an  
> example, I always have the same error:
>
>   File "md_in_python.py", line 8, in <module>
>     from MMTK.Trajectory import Trajectory, TrajectoryOutput,  
> SnapshotGenerator
>   File "/usr/local/lib/python2.6/dist-packages/MMTK/Trajectory.py",  
> line 24, in <module>
>     "because the netCDF module is missing.")
> MMTK.Utility.MMTKError: Trajectories are not available because the  
> netCDF module is missing.

This is most probably a problem related to the installation of  
Scientific Python. Try this (shell command line):

	python -c "import Scientific.IO.NetCDF"

If it does nothing, your installation seems fine and I have to start  
thinking again ;-)

If you get an error message starting with ImportError, then your  
ScientificPython installation is lacking the netCDF interface. There  
are two frequent reasons:

1) You installed ScientificPython before netCDF.

2) netCDF was installed in a non-standard location, where  
ScientificPython does not find it automatically.

In the second case, you get a warning when installing  
ScientificPython, but that warning can go unnoticed in the long  
compilation protocol that follows.

Konrad.
--
---------------------------------------------------------------------
Konrad Hinsen
Centre de Biophysique Moléculaire, CNRS Orléans
Synchrotron Soleil - Division Expériences
Saint Aubin - BP 48
91192 Gif sur Yvette Cedex, France
Tel. +33-1 69 35 97 15
E-Mail: research at  khinsen dot fastmail dot net
---------------------------------------------------------------------




More information about the mmtk mailing list