[MMTK] problems installing

Jay Billings jayjaybillings at gmail.com
Tue Jun 2 12:28:16 UTC 2009


I've had similar problems with netcdf and MMTK in the past. I believe the
solution is to change

#include <netcdf.h>

to

#include <netcdf/netcdf.h>

in trajectory.h.

Jay

On Tue, Jun 2, 2009 at 7:33 AM, Bjorge Solli <bjorge.solli at it.uib.no> wrote:

> Hi, I get this error when installing:
>
> [root at lpack64-fc10 MMTK-2.4.10]# python setup.py build
> running build
> running build_py
> running build_ext
> building 'MMTK_DCD' extension
> gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
> -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
> --param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC -fPIC
> -DLIBM_HAS_ERFC -D_LONG64_ -DEXTENDED_TYPES -IInclude
> -I/usr/include/python2.5 -c Src/MMTK_DCD.c -o
> build/temp.linux-x86_64-2.5/Src/MMTK_DCD.o
> In file included from Src/MMTK_DCD.c:9:
> Include/MMTK/trajectory.h:14:20: error: netcdf.h: No such file or directory
> error: command 'gcc' failed with exit status 1
>
> I know netcdf.h is in place, but mmtk obviously can't find it.
>
> [root at lpack64-fc10 MMTK-2.4.10]# rpm -ql netcdf-devel | grep netcdf.h
> /usr/include/netcdf/netcdf.h
> /usr/include/netcdf/netcdf.hh
>
> Is there any flags I can give the script to let it know where my
> include-files are located?
>
> System is Fedora 10, the above is from a 64-bit install, but I will also
> need it on 32-bit. I use Python 2.5 so I chose MMTK-2.4.10 as 2.6 seems
> to need Python 2.6. Compiling python is a tedious task I don't want to
> do if I can avoid it.
>
> Regards
> Bjørge Solli
>
> _______________________________________________
> mmtk maillist  -  mmtk at starship.python.net
> http://starship.python.net/mailman/listinfo/mmtk
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://starship.python.net/pipermail/mmtk/attachments/20090602/8af279aa/attachment.htm>


More information about the mmtk mailing list