[MMTK] bug in Trajectory?

Paul de Mascureau pauldem at caltech.edu
Tue Jan 8 23:09:37 UTC 2008


Dear mmtk users,

One month ago I reported a bug that came up when I ran the integrator for a
compound force field (LJ force field + harmonic force field for each atom).
The bug was solved when I replaced LennardJonesFF.py by a new version sent
by Konrad.
I am now trying to use nMoldyn with the trajectories I obtain, but it seems
like I hit a bug: xMoldyn calls Trajectory.py, and it creates a description
from the netCDF variable 'description' contained in my trajectory file.
After that it tries to build the skeleton:

            import Skeleton
            local = {}
            skeleton = eval(description, vars(Skeleton), local)
            universe = skeleton.make({}, conf)
            universe.setCellParameters(cell)
            object = universe

But the universe cannot be made from skeleton, and I get an "invalid syntax
error".

So my conclusion is that MMTK is creating a bad description, or at least a
description that cannot be used by xMoldyn. Has anyone already had this
problem?

Thanks for your help,

Paul

PS: I have attached the MMTK script I used to calculate the trajectories.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: LJ_harmonic.py
Url: http://starship.python.net/pipermail/mmtk/attachments/20080108/45c96ca4/attachment.txt 


More information about the mmtk mailing list