[MMTK] Hang in DomainFinder code

Gisle Sælensminde Gisle.Salensminde at bccs.uib.no
Wed Apr 5 12:40:30 CEST 2006


Konrad Hinsen wrote:

> On Apr 5, 2006, at 11:04, Gisle Sælensminde wrote:
>
>> Domainfinder. The function rigidMovement in DomainAnalysis.py calls a
>> function generalized_inverse in Numeric. This hangs somewhere down in
>> the numeric code (Lapack).
>
>
> There have been a couple of similar problem reports recently, all  
> concerning LAPACK routines shipped with Numeric and specific versions  
> of GCC. The solution that seems to help in all cases I have heard of  
> is to compile Numeric using
>
>     CFLAGS='-ffloat-store' python setup.py build
>
> instead of the simple
>
>     python setup.py build
>
This was indeed the problem. After recompiling with the -ffloat-store 
option it worked without problem.

> Indeed. What you could try (assuming that the above trick doesn't  
> work for you) is different BLAS versions and/or using the Fortran  
> version of LAPACK. This is badly documented (if at all) because the  
> details depend on compilers and various libraries, but anyone with  
> Fortran-C mixing experience under Linux should be able to get it to  
> work in an hour or so. You have a good chance of gaining some  
> performance as well.
>
The trick worked, so thank you very much.

The above sugestions can be well worth trying later, as well as moving 
the web application to a faster server.





More information about the mmtk mailing list