[MMTK] Problems loading certain PDB files

Peter mmtk at maubp.freeserve.co.uk
Wed Jan 18 11:54:40 CET 2006


I have tried the following on both windows (an older version of MMTK) 
and Linux (with MMTK 2.4.4)

I have been attempting to read PDB file 1A1Y (which the PDB marked as 
obsolete on 12 June 2000) with the following lines of python code:

import MMTK.Proteins
protein = MMTK.Proteins.Protein("1a1y.pdb")

Initially, this gives the following error:

IOError: Atom 1H of PDB residue ALA not found in residue Ala of object 
.Ala1

Aliases '1H', '2H', '3H' are missing in the database for peptide_nt and 
variants like peptide_nt_noh (missing in both MMTK 2.4.4 and MMTK 2.5.13)

Fixing this exposes a further class of problems, histidine residues with 
two hydrogens on the epsilon carbon (assuming I have the terminology 
right):

IOError: Atom HE2 of PDB residue HIS not found in residue His of object 
.His39

Editing the PDB file by hand to change theses HIS entries into HSE 
(histidine_epsilonh) seems to "fix" the problem and reveals yet another 
problem residue:

IOError: Atom 2HA of PDB residue GLY not found in residue Gly of object 
.Gly83

I have not investigated any further.

For my current task, I don't care about the hydrogens, so I tried using 
the following:

protein = MMTK.Proteins.Protein("1a1y.pdb", model="no_hydrogens")

However, this still seems to try and validate all the PDB atoms (even 
the hydrogens) during loading.

Thank you

Peter




More information about the mmtk mailing list