[MMTK] problem with findTransformation

Jaroslaw Kalinowski jak at biogeo.uw.edu.pl
Mon Nov 28 16:24:39 CET 2005


Thanks!

I was using the latest development version of your modules. I tried 
earlier version of MMTK (2.5.7), but I have not even thought about using 
other version of Scientific.

   Best regards,

Jaroslaw Kalinowski


>> I tried to align two structures but I could not obtain proper fit. I did:
>> [...] 
>
> At first I found this a bit puzzling, as I got a very good fit. Then I tried 
> it on my development machine and got a pretty bad one as well... Further 
> analysis showed that this was due to an incorrect tensor-vector product with 
> the new Pyrex implementation of the Vector class in ScientificPython 2.5.x. I 
> will have to look into that in more detail, according to my understanding it 
> should raise an exception rather than returning a wrong result...
>
> Assuming that you are using ScientificPython 2.5.x, I suggest temporarily 
> disabling the Pyrex Vector module. The simplest way is to delete the 
> corresponding compiled module, which is called Scientific_vector.so on Unix 
> platforms. You then use the old Python version, which is a bit slower but 
> tried and tested.
>
> Konrad.



More information about the mmtk mailing list