[MMTK] Fatal Python Error with NormalMode

konrad.hinsen at laposte.net konrad.hinsen at laposte.net
Wed Feb 23 19:17:03 CET 2005


On 23.02.2005, at 19:08, Justin Lemkul wrote:

> I thought it looked like an awfully uncommon error...

Considering that I haven't seen it in 10 years of Python use, that is  
probably a good description.

> incompatibility).  The machine did originally have 2.3 installed, but I
> upgraded to 2.4 a while ago in order to use Tkinter, since the  
> original 2.3

How did you upgrade? By compiling a framework version of 2.4 and  
replacing the Apple-provided 2.3?  That should be fine for MMTK, but  
you risk running into trouble elsewhere, as there are Mac applications  
out there that use Python, and assume that 10.3 has Python 2.3, which  
Apple guarantees.

Anyway, perhaps the simplest thing to try is to delete every trace of  
MMTK and then reinstall it using "python2.4 setup.py..." to be 100%  
safe.

Konrad.
--
------------------------------------------------------------------------ 
-------
Konrad Hinsen
Laboratoire Leon Brillouin, CEA Saclay,
91191 Gif-sur-Yvette Cedex, France
Tel.: +33-1 69 08 79 25
Fax: +33-1 69 08 82 61
E-Mail: khinsen at cea.fr
------------------------------------------------------------------------ 
-------




More information about the mmtk mailing list