[MMTK] A rather annoying newbie question on the netCDF interface

Roger Jarvis r.jarvis at postgrad.umist.ac.uk
Tue Jul 13 17:03:56 CEST 2004


Hi,

If anyone can help me with the following problem then it would be much 
appreciated.  I've been putting myself through the wringer trying to get 
the netCDF interface working in Scientific.  I've installed the following 
on windows...

1. Python 2.3.3 using Python-2.3.3.exe from python.org
2. Scientific python using ScientificPython-2.4.6.win32-py2.3.exe
3. netCDF for win32 - (\\python23\include\netcdf.h and netcdf.inc; 
\\python23\libs\netcdf.lib; also netcdf.dll in PATH)

When the netcdf.dll is installed and I type "from Scientific.IO.NetCDF 
import NetCDFFile" in IDLE, Python crashes, restarts and the following 
appears in a dialog box:
	"Runtime error!

	Program c:\program files\python23\pythonw.exe

	This application has requested the runtime to terminate in an unusual 
way.
	Please contact the applications support team for further information."

I've tried messing around with the netCDF installation and if I remove 
netcdf.dll, the crash doesn't happen but on the same command I get an 
"ImportError: cannot import name NetCDFFile".

The last thing I tried was importing the Scientific_netcdf.pyd, just to 
see if it would work.  I copied it into the folder \\Scientific\IO from 
the win32 dir and entered the command:
	import Scientific.IO.Scientific_netcdf

Traceback (most recent call last):
   File "<pyshell#1>", line 1, in -toplevel-
     import Scientific.IO.Scientific_netcdf
ImportError: DLL load failed: The specified module could not be found.

I admit to being completely out of my depth, but if anyone can clear up 
the tangled mess that I appear to have got myself into then I would be 
most grateful.

Kind regards,

Roger

-- 
Using M2, Opera's revolutionary e-mail client: http://www.opera.com/m2/



More information about the mmtk mailing list