[MMTK] I don't understand anymore (fwd)

Julien MOZZICONACCI pipo@lptl.jussieu.fr
Thu, 24 Oct 2002 10:02:26 +0200 (CEST)


Hi,
I am sorry, I send first this message to a wrong adress.
I tried to fix this little bug but I couldn't find what is wrong.

Julien Mozziconacci.

---------- Forwarded message ----------
Date: Wed, 16 Oct 2002 14:49:23 +0200 (CEST)
From: Julien MOZZICONACCI <pipo@donald.lptl.jussieu.fr>
To: Konrad Hinsen <hinsen@cnrs-orleans.fr>
Subject: I don't understand anymore


Hi Konrad,
I've just tried to run some small programs using your library. All of them 
used to run normaly but now they exit prematurly with this Traceback:

Traceback (most recent call last):
  File "dynamique299D.py", line 15, in ?
    universe = InfiniteUniverse(Amber94ForceField())
  File "/usr/lib/python2.2/site-packages/MMTK/ForceFields/__init__.py", 
line 18, in __call__
    return apply(ffc, args, kw)
  File 
"/usr/lib/python2.2/site-packages/MMTK/ForceFields/Amber/AmberForceField.py", 
line 156, in __init__
    parameters = readAmber94(main_file, mod_files)
  File 
"/usr/lib/python2.2/site-packages/MMTK/ForceFields/Amber/AmberForceField.py", 
line 28, in readAmber94
    Amber94 = AmberData.AmberParameters(paramfile, [(modfile, 'MOD4')])
  File 
"/usr/lib/python2.2/site-packages/MMTK/ForceFields/Amber/AmberData.py", 
line 80, in __init__
    self._readLJParameters(file, ljpar_set)
  File 
"/usr/lib/python2.2/site-packages/MMTK/ForceFields/Amber/AmberData.py", 
line 223, in _readLJParameters
    ljpar_set.addEntry(name, l[1], l[2], l[3])
  File "/usr/lib/python2.2/site-packages/Scientific/IO/FortranFormat.py", 
line 122, in __getitem__
    return self.data[i]
IndexError: list index out of range

Do you know what's appening?
Thank you.

Julien Mozziconacci