[MMTK] Problem with PyArray_API

Ioannis Ioannidis ioannis@cs.purdue.edu
Fri, 9 Nov 2001 19:36:12 -0500 (EST)


I have just installed MMTK-2.0 and I cannot use the MMTK_forcefield
module. The error I'm getting is that PyArray_API is missing. I saw an
earlier message about the same problem when you are using Numeric-20.0.
I'm using Numeric 20.2.1, Scientific 2.2 and Python 2.1.1. Do I still need
to install MMTK 2.2b6 and if so how can I get it? The link from the
homepage doesn't seem to work. Just in case, this is the exact error

    import MMTK_forcefield
ImportError: ld.so.1: python: fatal: relocation error: file
/homes/ioannis/lib/python2.1/site-packages/MMTK/sunos5/MMTK_forcefield.so:
symbol PyArray_API: referenced symbol not found

Thanks
Yannis