mmtk1.1b1 on DEC AlphaStation

Konrad Hinsen hinsen@cnrs-orleans.fr
Wed, 15 Jul 1998 11:55:29 +0200 (DFT)


> I've installed Python-1.5.1 on a DEC AlphaStation 250 4/266 running
> OSF1/4.0a.  I used:
>
> 	    gcc-2.8.1	    
>	    libz-1.1.3
>	    Tcl/Tk-8.0
>	    Tix4.1.8.0
>	    BLT2.3
>	    netcdf-3.4

Which version of NumPy did you use? There was some Alpha-related
bug fixed not too long ago.

> MMTK installed okay, but NONE of the sample scripts work, nor does the
> "A simple example" in overview.html (once the bugs/typos are fixed!).

Thanks for pointing out the typos; I just fixed it for the next
release...

> I've attached the outputs below my signature block.  By manually
> typing in the scripts which failed due to Floating Point Exceptions, I
> found them caused by calls to minimizer() or integrator().  dlpoly.py
> failed with an "energy evaluator defined only for universes" message.
> Neither protein_analyze.py nor I could find 4q21.pdb.
> protein_construction.py ran into an unknown atom type.

dlpoly.py hasn't worked for some time, since I didn't update
it with new MMTK versions. It should have disappeared in 1.1, and
it will definitely disappear in 1.2. In fact, I am considering dropping
the whole DLPOLY module; I have given up trying to use DLPOLY, and
I don't know of anybody else who is actively using this export
facility.

As the manual explains, you must get the PDB 4q21 and 6q21 yourself
to run the example protein_analysis.py. There's no point in including
these rather large files in the MMTK distribution; anyone can get
them from the nearest PDB server.

The error in protein_construction.py is caused by a bug (or perhaps a
"feature incompatibility") in the module PDB.py, outside MMTK.
This module doesn't recognize atom names that start with digits as
hydrogens. I have fixed this a while ago, but never put the fixed
version on the Web! I'll do this as soon as possible (and let the
list know about it).

What really worries me is the crashes with the remaining examples. I
suppose they are somehow Alpha-related, since these examples
definitely work on the machines I use (that's AIX, Linux, and HP/UX).
They even work on my Alpha installation, but that is still using
Python 1.4, because I could never get Python 1.5.1 installed
on the Alpha. I hope that someone else can shed some light on this.
-- 
-------------------------------------------------------------------------------
Konrad Hinsen                            | E-Mail: hinsen@cnrs-orleans.fr
Centre de Biophysique Moleculaire (CNRS) | Tel.: +33-2.38.25.55.69
Rue Charles Sadron                       | Fax:  +33-2.38.63.15.17
45071 Orleans Cedex 2                    | Deutsch/Esperanto/English/
France                                   | Nederlands/Francais
-------------------------------------------------------------------------------